Audience

Handel users who have xMAP hardware and xManager users.

Warning

Neither the PLX driver nor xManager is supported on 64-bit versions of Windows XP, Vista or 7.

Introduction

Starting with version 1.1.7 of Handel we are now distributing v6.3.1 of the PLX driver. (Previously we were distributing v5.2.) Though we try to avoid upgrades that require manual changes on the part of our users, this new version of the driver is required to better support XIA users who run on Windows 7. Due to incompatible changes in the PLX API between v5.2 and v6.3.1, we are unable to support multiple versions of the PLX driver in Handel and as such this will be a forced upgrade for all xMAP users.

Instructions

  1. Verify that all xMAP modules are installed in the crate and powered on.
  2. Open the Device Manager and expand the Other Devices section. In this section all of your xMAP modules should be listed.
  3. For each xMAP module listed
    1. Select Properties, then the Driver tab and lastly the "Update Driver..." button.
    2. The Hardware Update Wizard should open. Select "No, not this time" on the first page and press "Next".
    3. Choose "Install from a list of specific location (Advanced)" on this page. Press "Next".
    4. Choose "Search for the best driver in these locations" and check the "Include this location in the search" box.
    5. Press "Browse" and navigate to <Handel v1.1.7 (or greater) installation directory>\redist\drivers\plx. Press "Next".
    6. The Wizard will now install the new driver.
    7. Follow the rest of the instructions.